jSunnyreports 2.0.8 released

I just released 2.0.8 which contains a few minor updates in the JSON engine. Some JSON files were invalid after creation and as a result the website would not work properly. Note: The invalid json files are not automatically fixed by this release, these files have to be overwritten manually.

Basically what I did was run everything locally on my laptop ( copy from my server ). After the first (long) run I copied all the json files back to my server.

Everyone who’s using 2.0.7 just update jsunnyreports.jar and you’re set.

 

 

6 Comments

  1. Hans

    I am not at home now. Have to wait. Until this evening.

  2. Rabby

    Hello Martin,

    Just wanna test the update but got this error below; i’ve updated from 2.0.7, just copied the jsunnyreports.jar right as noticed in the update readme;

    “Exception in thread “main” java.lang.UnsupportedClassVersionError: nl/mk/jsunnyreports/JSunnyReports : Unsupported major.minor version 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:442)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:64)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:354)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:312)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)”

    Thanks for your help đŸ˜‰

  3. Doudy

    Martin,
    Tevreden dat u terug bent
    Doudy

  4. Remco

    Just updated ver 2.0.7. to 2.0.8

  5. Michel

    Hi martin,
    Just like Raby I encountered the same problem. Any idea how to fix it? I had to refer back to 2.0.7

  6. Martin Kleinman

    JSR 2.0.8 is compiled against Java 1.8 which means that Java 1.7 doesn’t work at the moment.

    I will have to modify my development environment to get it to work again with older versions of java.

    Other option would be to update the java version on your system.

Comments are closed.